Minecraft 1.14 Support - How to downgrade (for now)

Discussion in 'Announcements' started by HiveTeam, Apr 25, 2019.

Thread Status:
Not open for further replies.
  1. HiveTeam

    HiveTeam Official Post Administrator

    Joined:
    Mar 1, 2017
    Messages:
    69
    Ratings:
    +2,436
    Edit as of 30/04/2019:
    We now support versions 1.8.9 through 1.14 - while we allow joining and playing on 1.14, for the best experience we'd recommend using 1.8. Thank you for your patience while we updated!

    As many of you will know 1.14 was recently released. We are still working away on making sure we fully support this as well as every other version from 1.8 onward - as soon as we are ready for it we will be sure to let you know.

    #1
    • Like Like x 12
    • HYPE! HYPE! x 3
    • Informative Informative x 2
    • Agree Agree x 1
    • List
Thread Status:
Not open for further replies.

Share This Page